paint problem

View previous topic View next topic Go down

paint problem

Post  mick 100 on Thu 29 Nov - 20:18:34

hi to all , has anyone had a problem with anti corrosive primer not sticking when it's dry . i can chip it off with my nail . all clean metal and degreased . craftmaster paint . scratch

mick and claire

mick 100

Number of posts : 91
Location : sussex
Registration date : 2012-10-13

View user profile

Back to top Go down

Re: paint problem

Post  Adam Brown on Thu 29 Nov - 21:21:28

Its not something I've really heard of (being Craftmaster). PM me with you phone number if you like and I'll give you a call tomorrow. I'll run it past the lab and see what we can come up with

Adam Brown

Number of posts : 61
Location : Cambridge
Registration date : 2012-02-07

View user profile

Back to top Go down

Re: paint problem

Post  lynnr on Thu 29 Nov - 21:53:16

Could be as simple as a bad batch of paint.

lynnr

Number of posts : 2689
Age : 48
Location : Highland, 4inch showman
Registration date : 2010-08-06

View user profile http://www.pbase.com/uisge

Back to top Go down

Re: paint problem

Post  Robfishman on Thu 29 Nov - 22:00:14

Either way Adam will get to the bottom of it.

Robfishman

Number of posts : 944
Age : 41
Location : Chandlers Ford Hampshire 4inch showman
Registration date : 2010-11-26

View user profile http://www.robertfish.net

Back to top Go down

Re paint problem

Post  mick 100 on Sun 9 Dec - 20:25:33

paint problem fixed , a big thank you to adam . our metal was clean but not rough enough , the flap wheel was leaving the surface to smooth and we were using the wrong degreaser .
many thanks adam

mick and claire Very Happy .

mick 100

Number of posts : 91
Location : sussex
Registration date : 2012-10-13

View user profile

Back to top Go down

Re: paint problem

Post  Dan on Mon 10 Dec - 11:40:15

Glad your problem is solved!

mick 100 wrote:we were using the wrong degreaser .

Which degreaser were/are you know using?


Dan

Number of posts : 122
Location : East Anglia
Registration date : 2011-09-07

View user profile

Back to top Go down

Re paint problem

Post  mick 100 on Tue 18 Dec - 18:36:01

hi dan , i was using brake and clutch cleaner from my workshop but now use thinners , Very Happy

mick 100

Number of posts : 91
Location : sussex
Registration date : 2012-10-13

View user profile

Back to top Go down

Re: paint problem

Post  Sponsored content Today at 7:39:56


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum